[Skip to Content]

V3 Trouble Shooting FAQ


Dinkytown V3 Trouble Shooting FAQ


Use this FAQ to help diagnose and address common questions that come up with different calculator deployments. Please contact support with any questions you have when deploying or using the calculators. Feel free to contact us via email at or by phone at (612) 331-2291.

More information can be found at:


How do I get rid of the "KJE Calculator License Not Found for: (website)" on my calculators?

All calculator deployments are keyed to a specific production website. Normally, a license is limited to one website unless a special use license has been purchased. If you see the message above you may have deployed the calculators on a website different than the one originally licensed. We can change the production website for you which you can install with a normal update from us. Please email us at KJESupport@dinkytown.net to get the production license changed.

If you see this error message on a development, test or QA server please email us at the link above. We can add as many development, test or QA servers to your license key as you need to support your website.


We use iFrames and the calculators don't appear for IE9

When the calculators load, a tiny bit of code is called to initialize the calculator. Normally the code is called when the browser's page has loaded (the actual event is DOMContentLoaded). IE7 and IE8 don't have send an event notification to let the code know its time to initialize the calculator, so we have a bit of code to force it to happen. This is normally the last line of the Params .js file of each calculator. IE9 usually sends this event just fine, but it fails when the calculator page is launched within an iFrame. We generally don't recommend iFrames for aesthetic reason, but this issue is a technical one that can be fixed by changing the code for IE7 and IE8 that forces an initialization of the calculator to apply to all browsers. If you contact us, we can modify your calculator package to include this bit of code for you. You can then redownload your full calculator package and replace the PARAMS files Or, if you prefer, you can modify the Params.js files for each of your calculators by changing the line:

if (KJE.IE7and8) KJE.init();

to

KJE.init();

Please note that we have code in place that will prevent a calculator from initializing twice, if a second attempt to initialize happens it is just ignored.

Internet Explorer 9 is displaying slowly and doesn't have rounded corners, can this be fixed?

Internet Explorer 9 has the ability to display almost all advanced HTML5 content including rounded corners and our advanced graphs that use the canvas element. However, IE9 has several compatibility modes that can force content to display as seen in IE7 or IE8. This limits the calculator's ability to use many of these advanced properties. To fix this, make sure you have two things on each page.

  1. Valid doctype such as the first line of the HTML page. All HTML pages provided by KJE will have this in place:

    <!DOCTYPE HTML PUBLIC '-//W3C//DTD HTML 4.01 Transitional//EN' 'http://www.w3.org/TR/html4/loose.dtd'>

    Or:

    <!DOCTYPE HTML>

    Note the second doctype is technically correct HTML5 code, but the first doctype has been tested and works with older browsers such as IE7 and IE8 that predate HTML5. The calculators render identically with either doctype (HTML5 browsers simply ignore everything after the text HTML).

  2. Make sure you have the IE=Edge meta tag to fore IE to use it's most current rendering engine.

    <meta http-equiv="X-UA-Compatible" content="IE=Edge">

    As long as these two line are correctly included in your HTML document all version of IE9 should work as expected regardless of an individual user's browser settings. It also works to prevent people from accidentally using IE9 in compatibility mode (or even allowing them to have the option to use the "broken page" icon to switch to it). Also note that older Doctypes like those for XHMTL can actually cause force IE9 into rendering with IE8 or IE7 compatibility mode. It is best to stick with one of the two options above.